浏览器版本低!无法浏览完整内容,建议升级或更换浏览器。
第1行: 第1行:
 
{{androidsdk-sidebar}}
 
{{androidsdk-sidebar}}
<h1>相关下载</h1>
+
<div class="bluetitle"><div class="services-title-text">Android 地图 SDK v4.5.0</div></div><div class="broad">因采用分包形式,旧包无法与新包同时混用,请将之前所有旧包(so和jar)全部替换为新包。</div><div class="serve-explain-text"><div class="serveintoor-title">'''开发包下载'''</div>
<div id="andsdk-download">
+
注:进入百度LBS Android SDK下载平台,结合自身需求、自定义选择业务功能,打包下载所选功能开发包。
    <div id="dev_wikiuse_iframe">
+
<div class="go-download-btn">[http://lbsyun.baidu.com/sdk/download?selected=mapsdk_basicmap,mapsdk_searchfunction,mapsdk_lbscloudsearch,mapsdk_calculationtool,mapsdk_radar 自定义下载]</div></div><div class="serve-explain-text"><div class="serveintoor-title">'''示例代码下载'''</div>
        <div dir="http://lbsyun.baidu.com/skins/MySkin/resources/iframs/sdkandev-download.html?v450">
+
注:包括类参考、示例代码(覆盖物开源代码也可在BaiduMapsApiDemo工程中找到。)
        </div>
+
<div class="go-download-btn">[http://mapopen-pub-androidsdk.bj.bcebos.com/map/BaiduMap_AndroidSDK_v4.5.0_Sample_demo.zip 下载]</div></div><div class="serve-explain-text"><div class="serveintoor-title">'''使用说明'''</div>
    </div>
+
1. Android地图SDK自 v3.0.0版本进行了全面的接口优化、升级,因此不能兼容3.0.0之前的版本。3.0.0版本接口设计更合理,降低开发者学习使用成本,欢迎大家使用!
 +
 
 +
2. 若需使用Android SDK,请先下载对应版本的lib库,在Android工程中引用jar和so文件。
 +
 
 +
3. 该版本SDK提供矢量版地图。
 +
 
 +
4. Lib库和示例代码下载包中均含有readme.txt,可阅读参考,有助您的开发。
 +
 
 +
5. 自v3.6.0起,官网不再支持地图离线包下载,所以SDK去掉“手动导入离线包接口”,SDK在线下载离线包接口仍维持不变。
 +
 
 +
6.注意:自v2.1.3版本起,SDK采用了全新的Key验证体系,如果您选择使用v2.1.3及以后的版本, 需申请全新的Key。
 +
 
 +
7.自V3.6.0起,'''原内置覆盖物相关类代码开源''',包含:OverlayManager /PoiOverlay /TransitRouteOverlay /WalkingRouteOverlay /BusLineOverlay
 +
 
 +
[http://lbsyun.baidu.com/index.php?title=androidsdk/guide/key 点击查看申请ak流程>] [http://bbs.lbsyun.baidu.com/forum.php?mod=viewthread&tid=3979&extra=page=1 历史版本>]
 
</div>
 
</div>

2017年10月26日 (四) 06:19的版本

Android 地图 SDK v4.5.0
因采用分包形式,旧包无法与新包同时混用,请将之前所有旧包(so和jar)全部替换为新包。
开发包下载

注:进入百度LBS Android SDK下载平台,结合自身需求、自定义选择业务功能,打包下载所选功能开发包。

示例代码下载

注:包括类参考、示例代码(覆盖物开源代码也可在BaiduMapsApiDemo工程中找到。)

使用说明

1. Android地图SDK自 v3.0.0版本进行了全面的接口优化、升级,因此不能兼容3.0.0之前的版本。3.0.0版本接口设计更合理,降低开发者学习使用成本,欢迎大家使用!

2. 若需使用Android SDK,请先下载对应版本的lib库,在Android工程中引用jar和so文件。

3. 该版本SDK提供矢量版地图。

4. Lib库和示例代码下载包中均含有readme.txt,可阅读参考,有助您的开发。

5. 自v3.6.0起,官网不再支持地图离线包下载,所以SDK去掉“手动导入离线包接口”,SDK在线下载离线包接口仍维持不变。

6.注意:自v2.1.3版本起,SDK采用了全新的Key验证体系,如果您选择使用v2.1.3及以后的版本, 需申请全新的Key。

7.自V3.6.0起,原内置覆盖物相关类代码开源,包含:OverlayManager /PoiOverlay /TransitRouteOverlay /WalkingRouteOverlay /BusLineOverlay

点击查看申请ak流程> 历史版本>

  • 文档根本没法用

  • 文档水平很差

  • 文档水平一般

  • 文档不错

  • 文档写的很好

如发现文档错误,或对此文档有更好的建议,请在下方反馈。问题咨询请前往反馈平台提交工单咨询。

提交反馈

拖动标注工具

添加矩形标注

添加箭头标注

完成

取消