浏览器版本低!无法浏览完整内容,建议升级或更换浏览器。

简介

什么是百度地图Flash API?

百度地图Flash API是一套由ActionScript3.0语言编写的应用程序接口,它能够帮助您在Flex/Flash项目中快速的构建地图应用。百度地图Flash API包含了基本的地图接口。

面向的读者

Flash API是提供给那些具有一定Flash AS3.0编程经验和了解面向对象概念的读者使用。此外,读者还应该对地图产品有一定了解。

您在使用中遇到任何问题,都可以通过API论坛反馈给我们。

获取API

Flash API由AS3.0语言编写,并发布为swc文件。下载 BMap.swc,在您的项目中引入该swc后即可使用Flash API。

兼容性

需要使用ActionScript3.0进行开发,要求Flex SDK版本为4.0以上。

运行环境要求FlashPlayer10.0以上。

Flash API本身不依赖于任何第三方的类库,不会与您项目中的第三方类库冲突。

问题解答

如果您在使用百度地图Flash API中遇到问题,请尝试通过以下途径解决:

确认您的Flex SDK版本、Flash Player版本符合要求。

访问百度地图API吧,查找相关问题的帖子,或者将您的问题发布到贴吧中。

  • 文档根本没法用

  • 文档水平很差

  • 文档水平一般

  • 文档不错

  • 文档写的很好

如发现文档错误,或对此文档有更好的建议,请在下方反馈。问题咨询请前往反馈平台提交工单咨询。

提交反馈

拖动标注工具

添加矩形标注

添加箭头标注

完成

取消